2次元グラフ作成ツール Tgraph.exe

・Tgraphとは
 Tgraph は1行の中にいくつかの変数が規則正しく並んでいるASCII 形式のテキストファイル、Microsoft Excelのブック(*1)、コンマで区切られたCSVファイルまたはタブ区切り、スペース区切りのデータファイルおよびバイナリ形式のデータファイルから、任意の変数を選んで作画する2次元グラフ作成ツールです。簡単な操作でプレゼンテーションにも耐えうる綺麗な出力が得られます。出力先はプリンタ、クリップボード、メタファイル、JPEGファイルになっており他のワープロソフト等に絵を貼り付けて編集することも容易です。

   (*1) Microsoft Excel がインストールされている必要があります。
     ver.3.2以降はExcel Bookを直接読み込むので不要
     ver.4.0.0からは xlsx 形式にも対応

実行イメージ

・特徴
    各種のデータファイルの形式に対応(テキスト,CSV,Excel,Binary)
    簡単操作で綺麗な出力
    多項式近似、スプライン曲線など多彩な曲線が使える
    重ね書きが容易
    X軸共通でY軸が異なるグラフが5つまで作成可能
    矢印、文字列、画像ファイルを貼り付けることが可能


・著作権

 このプログラムはフリーウェアです。著作権は作者にあります。このプログラムは次に述べる使用条件を満たせば無料で使用することができ、転載、再配布も自由に行なえます。転載、再配布する場合は、実行ファイル一式とこのドキュメントを一緒に転載、再配布してください。また、バージョンアップの際には、できる限り新バージョンの配布と旧バージョンの破棄を行って頂けるとありがたいです。書籍の付録フロッピー、CD-ROM等に収録される際には、必ず作者まで電子メールでお知らせください。無断で商目的(手数料を含む有料配付・商品のオマケ等)に利用することを禁止します。


・使用条件

 このプログラムを使用したことによって生じたいかなる損害についても作者はその保障義務を一切負わないものとすると言う条件に同意していただいた方だけが、このプログラムを使用することができます。


・サポート

 バグ、要望等がありましたらE-mailにお願いします。メールで頂いた場合は返事が書けないかもしれませんがその時はすみません。バグ、要望にはなるべく対応したいですが自らの能力と時間の関係ですべてに対応できないかもしれません。


・改正履歴

ver. 4.1.4.0 (2016/06/22)
・コンパイラを Embarcadero C++Builder 10.1 Berlin に変更。
・旧バージョン(ver.3.1.0以前)で作ったtgwファイルの読み込みに失敗する不具合を修正。

ver. 4.1.3.1 (2016/02/21)・・・アップデートチェックには反映しない
・配布元サーバー移行によるURL変更に伴う修正。

ver. 4.1.3.0 (2015/11/01)
・コンパイラを C++Builder XE8 に変更し、32bit版だけでなく64bit版もリリースする。
・ブロック枠表示のOn/Off(グラフ画面でのポップアップメニューで設定)をページ毎に記憶するようにした。
・表形式のブロック選択の場合に、Ctrl+Altを押しながらのドラッグで指定列の情報(線種、マーク、色など)のみをコピーするようにした。Ctrlだけの場合や、ツリー形式のブロック選択の場合は、従来通りブロック名、タグ名以外のすべての情報をコピーされる。また、アンドゥ(最後の操作のみ)を可能とした。表でのポップアップメニューから実行する。
・文字列、矢印、画像ファイルの設定ウインドウのダブルクリックでエラーする場合があるのを修正

ver. 4.1.2.0 (2015/05/26)
・「プロジェクトを名前を付けて保存」でエラーする不具合を修正。

ver. 4.1.1.0 (2015/02/14)
・拡張子が xlsm のファイルをExcel Book と認識しなかった不具合を修正。(xlsb は未対応)

ver. 4.1.0.3 (2014/09/25)
・Embarcaderoから連絡があった BMPファイル読み込み処理に対する脆弱性情報に対する対応を行った。
・BOMありのUnicodeファイルの読み込みに失敗するのを修正。以下のUnicode形式のデータファイルに対応した。
   UTF-8(BOMあり)、UTF-8、
   UTF-16(BOMあり)、UTF-16、UTF-16BE(BOMあり)、UTF-16BE、
   UTF-32(常にBOMあり)、UTF-32BE(常にBOMあり)

ver. 4.1.0.2 (2014/06/19)
・ExcelからのTGWファイル新規作成ができなくなっていた不具合を修正。

ver. 4.1.0.1 (2014/06/18)
・TGWファイルやデータファイルの履歴メニューにリンク切れファイルの削除、すべての履歴のクリアを追加した。
・TGWファイルを切り替えたときに、稀に軸選択の情報が消えてしまうことがある不具合を修正。
・その他、細かな修正。

ver. 4.1.0.0 (2014/02/07)
・タブ毎にスケール設定(最大、最小、ピッチ等)を変更できるようにする。タブ上でのポップアップメニューか[オプション]-[目盛り]で従来通りの共通の設定にすることも可能。また、Altキーを押しながらタブ切り替えすると、一時的に設定とは逆の作動を行う。
・プリンタの設定ダイアログに「改ページしないで複数のグラフを合成する」チェックボックスと「コピー」ボタン、「印刷プレビュー」ボタンを追加。改ページせずに複数のタブ設定のグラフを合成して出力することができる。「コピー」ボタンではメタファイル形式でクリップボードにコピーされる。
・描画選択ウインドウの「既存の描画設定コンボボックス」を止める。従来の設定は読み込み時にタブに変換される。
・時間軸での目盛り文字を切りの良い値で表示するように修正。ピッチが月、年単位の時には厳密にはプロット座標値と必ずしも一致しないことになるが線幅程度の誤差に収まるので大きな問題はない筈である。
・画像のファイル出力にPNG形式を追加した。圧縮レベルは[オプション]-[その他]で指定する。(0は非圧縮、9で最大圧縮となる)
・タブをマルチラインに変更。
・xlsxファイルの読み込み時にエラーが発生するのを修正。
・Vista以降でオープンダイアログの初期フォルダーが、常にレジストリに保存されたフォルダーになってしまうのを修正。

ver. 4.0.2.0 (2013/01/26)
・INIファイルの場所を実行ファイルと同じフォルダーに置けるようにした。[オプション]-[INIファイルをTgraphフォルダーに]で指定する。ただし、UACが有効でフォルダーへのアクセスには管理者権限が必要なときは、この機能は利用できない。
・ステータスバーのデザインをヘルプ表示付に変更した。
・日本語環境で印刷設定ダイアログが英語になっていたのを修正。

ver. 4.0.1.3 (2012/07/17)
・マルチモニタ環境でセカンダリモニタに表示しているときに、タブ削除を行うとフリーズする不具合を修正。

ver. 4.0.1.2 (2012/06/16)
・日本語リソースの一部が英語になっていたのを変更。

ver. 4.0.1.1 (2012/06/15)
・実行ファイルの一部が日本語のままだったのを英語に変更。

ver. 4.0.1.0 (2012/06/15)
・コンパイラを C++Builder XE2 に変更。
・[ファイル]-[出力]-[ファイル出力] でエラーが発生して出力できなくなっていた不具合を修正。また、品質が悪いPDF出力を止める。(PDF出力は仮想プリンタのPDFライターを使ってください)
・Windows Vista 以降でユーザー・アカウント制御(UAC)が有効になっている時、システムに拡張子.tgwの関連付けができなかった不具合に対処。別の実行ファイル(TgraphAdminUtil.exe)を管理者権限を要求して呼び出すようにする。
・[ヘルプ]-[目次]でヘルプファイルがオープンしなかった不具合を修正。
・「x」ボタンでタブを削除するときにCtrlキーを押しながらクリックした場合は確認ダイアログを出さずに直ちに削除するようにした。
・軸選択、ブロック選択などの表において、Ctrl+Alt+C で固定セルを含むすべての文字列をクリップボードにコピーできるようにした。
・起動時にネットワーク経由でアップデートの有無をチェックをできるようにした。([ヘルプ]-メニュー)
・実行ファイルの言語を英語に変更。日本語OSでは日本語リソース(Tgraph.jpn)を使用するようにした。

ver. 4.0.0.0 (2011/10/22) Unicode対応
・コンパイラをC++Builder2010に変更。Unicode対応バージョン
・ブロック選択を従来の表形式だけでなくツリー形式も可能とする。
・Excel 2007以降のxlsx形式のファイルに対応。
・Vista以降(またはXPでネットワーク先のTgraph.exeを実行させたとき)でのINIファイルの保存先をアプリケーションデータフォルダに変更した。
・ドッキングコントロールの不具合を修正
・ブロック名のディフォルトに改行コードが含まれるとき、状態を保存しない不具合を修正。
・ツールバーのボタンのデザインを変更した。
・ヘルプファイルをHTML形式に変えた。
・英語版リソースの配布を止める。

ver 3.3.0 (2010/04/10)
・Windows2000以前対応の最終バージョン。以降はXP以降のみの対応となる。
・データがバイナリファイルのときに実行時エラーが出ることがあるのを修正。

    ・
    ・
  <中略>
    ・
    ・
ver 1.00(1997/12/12)
・初版

戻る